HomeFAQRegisterLog in
Sc2MapPro 1.4.5 Released (patch 2.0.10 supported)
Diablo 3 Simple Hack released.
Get your official membership and try the new Swtor Bot!
Try the 4 state auto start, the auto inject-chrono-mules-researches and the macro bot!
GBot 1.4.1 Released! Pve Bot, speed hack, teleport hack and much more!
Want to donate something to help us?
Latest topics
» how to buy Sc2MapPro ?
by friuns Sat Aug 23, 2014 4:53 pm

» How to use my Map pro account pls??
by Admin Tue Jun 24, 2014 9:35 am

» Current Patch
by SC2Dude Thu Jun 05, 2014 9:14 pm

» error playing today
by bellaPatricia Sun Mar 16, 2014 7:43 pm

» New Units in HOTS not showing up on resources hud.
by bellaPatricia Sun Feb 16, 2014 9:53 am

» So much of silence
by parrupio Sat Feb 01, 2014 7:33 pm

» Signature Scanner 1.2.1 for SC2
by bellaPatricia Tue Jan 21, 2014 4:16 pm

» Downloaded and installed
by parrupio Sat Jan 11, 2014 4:29 pm

» working good
by parrupio Sat Jan 11, 2014 12:59 am

» I have a question
by Admin Mon Nov 25, 2013 8:06 am

» "Error into fields number line"
by Legionary Thu Oct 31, 2013 7:02 pm

» I'm having difficulties installing the MapHack
by Admin Mon Aug 12, 2013 6:43 am

» Auto Larva
by theDrag Thu Jun 27, 2013 1:02 pm

» FPs problems?
by thiele Mon Jun 03, 2013 2:56 pm

» HotS UNITS
by Admin Tue May 28, 2013 5:44 pm

» Little success story... and an obvious thumbs up!
by SC2Dude Sat May 18, 2013 7:42 pm

» Leveling SC2 HoTS/WoL up to MASTER from BRONZE
by LevelingSC22 Tue May 14, 2013 6:11 pm


Share | 
 

 Multiple Monitors - Bot works, but no overlay. (solved by mazeez)

Go down 
AuthorMessage
refringe



Posts : 3
Join date : 2011-02-18

PostSubject: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 3:30 pm

First of all, I'm using a multiple monitor set-up; I don't know if that has anything to do with anything, but I just thought I'd mention it. The issue is there's no overlay. That is; no minimap overlay, no autobuild overlay, and no see-what-the-other-players-are-doing overlay. The game looks exactly like it would if there was no hack.

The bot is working fine, however.

Any help would be great. Thanks!


Last edited by wootcandy on Mon Mar 14, 2011 5:49 am; edited 1 time in total (Reason for editing : Edited title ;))
Back to top Go down
Takino



Posts : 974
Join date : 2010-11-24

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 3:35 pm

Not sure if this will help but have you tried?
http://www.actualtools.com/multiplemonitors/

Back to top Go down
Admin
Admin
avatar

Posts : 2545
Join date : 2010-11-13
Age : 48
Location : Solar system

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 3:37 pm

Or here:

http://www.murgee.com/

or you can try the attached program.

Thx Dave, always the best Smile
Attachments
DualMonitorTools-1.5-exe.zip
DualMonitorTools 1.5.0
You don't have permission to download attachments.
(138 Kb) Downloaded 3 times
Back to top Go down
http://www.gamebotdev.com/
refringe



Posts : 3
Join date : 2011-02-18

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 3:47 pm

Hey guys. Thanks for getting back to me so quickly. The issue is still with the hack, not multi-monitor functionality. Here's a screen-shot of me using the hack:
https://i.imgur.com/DkPEs.jpg

There's no overlay, but the bot is still working.

How do I get the overlay to show up?
Back to top Go down
Admin
Admin
avatar

Posts : 2545
Join date : 2010-11-13
Age : 48
Location : Solar system

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 3:50 pm

The bot works cause it uses different code sections.
Probably larva injection or chrono will not work properly.

Remember that you must set up sc2 in windowed or full windowed mode.

But it's strange cause it should use the first monitor as default.
Back to top Go down
http://www.gamebotdev.com/
refringe



Posts : 3
Join date : 2011-02-18

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 4:01 pm

Ah, that was the problem. After changing it to windowed mode I can see the overlay.

Chrono's not working, I guess that's because I have to align the mini-map overlay?
Back to top Go down
Admin
Admin
avatar

Posts : 2545
Join date : 2010-11-13
Age : 48
Location : Solar system

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 4:04 pm

I think yes.
Probably you have to align one or two pixels, check if into protoss hud the chrono checkbox is enabled.
Back to top Go down
http://www.gamebotdev.com/
wootcandy

avatar

Posts : 279
Join date : 2011-01-08

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sat Feb 19, 2011 4:06 pm

My 1080 47" TV is hooked up to my HDMI out on my Graphics Card and my monitor on a DVI (also 1080). Duplicate displays not extended.

Are your displays the same resolution? Unsure if this matters cause I don't have a different monitor and never thought to test with laptop + monitor.

Chrono, Inject have always worked fine for me. My TV usually isn't on the right input for the computer when I'm playing starcraft 90% of the time but I do not switch my duplicate displays.

I accidently had full screen one time and experience same as you. Can't see HUDs but things like autostart do indeed work.
Back to top Go down
mazeez

avatar

Posts : 5
Join date : 2011-03-12
Location : Rome

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sun Mar 13, 2011 12:56 pm

Im experiencing the same problem, bot is running but no HUD at all, and I've a 3 monitors set up.
I always manage my desktops with a software like the ones proposed in this post, wich gives me taskbars on each display and several controls, but still no HUD can be viewed.
I try switching Sc2 to Windowed but I can't choose the resolution, so I had to switch back Windowed(Fullscreen).
Any hint will be appreciated... Very Happy
Back to top Go down
Admin
Admin
avatar

Posts : 2545
Join date : 2010-11-13
Age : 48
Location : Solar system

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sun Mar 13, 2011 1:41 pm

Hello!

Be sure to use windowed or full windowed mode.
In full d3d screen mode the huds cannot be displayed cause windows don't permit to see dialogs or windows in this screen mode.
You can then move the huds to your secondary monitor, and sc2mappro should save them with these new positions.
Back to top Go down
http://www.gamebotdev.com/
Andrect



Posts : 55
Join date : 2011-02-15
Age : 31
Location : Brazil

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sun Mar 13, 2011 2:05 pm

is it possible to use the hack with 3D ???

i mean, i have 3d vision + monitor.. and i usually play sc2 with it.. but i didnt figure out a way to use the hack with the 3d hehe ..

whenever i enable the hack, the 3d is gone .. or if i put 3d on, the hack is gone

i guess its not supported due to the fact that it creates 2 monitors in the same screen??

like .. 1 normal + 1 more dept for the 3d ??



1 monitor only.. but 3d enabled..
Back to top Go down
mazeez

avatar

Posts : 5
Join date : 2011-03-12
Location : Rome

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sun Mar 13, 2011 2:36 pm

Ok I managed to figure it out and got it working.
Here's my little "raw how-to" for users with multiple monitors:

- Go to Window's resolution options and disconnect every other monitor except the main one wich has Sc2 running (of course)
- Start Starcraft 2, then go into graphic options and set "Windowed" (NOT fullscreen)
- Start Sc2MapPro, then Starcraft 2 (make sure to uncheck the hiding of HUDs in Sc2MapPro options tab)
- Creating a custom game you should see the HUDs. Can happen to not see them all or a little bit screwed up, but don't worry and try pressing couple of times F7 key to reload Sc2MapPro and luckily the HUDs will appear.
- Without closing Starcraft 2, ALT+TAB to desktop, go to Window's resolution options and enable the other displays back.
- Now the Starcraft 2 window could get glitchy, or HUDs can appear on other displays
- Go back to the game, disable the bot, and move all the HUDs in the gaming scene with some ALT+TAB and dragNdrop combos Wink
- In Starcraft 2 graphic options, set Windowed (Fullscreen) back
- Close and restart Starcraft 2 and it should run smoothly in Windowed Full screen, with the overlayed HUDs.
- Position the HUDs in the Starcraft 2 to match the gaming scene as liked. Make sure to adjust the minimap. Now the goal should be achieved and the HUDs should be working as intended.

I hope everything is clear, but feel free to ask for more details if needed.
Happy gaming!

Ps. Tested on Windows Seven 64 Bit

Update:
When joining games with several players, like 4v4 or customs, HUDs can probably go on other displays: just keep the monitors on and move them where preferred.


Last edited by mazeez on Sun Mar 13, 2011 7:33 pm; edited 2 times in total
Back to top Go down
Admin
Admin
avatar

Posts : 2545
Join date : 2010-11-13
Age : 48
Location : Solar system

PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   Sun Mar 13, 2011 3:06 pm

cheers

Great work!
Back to top Go down
http://www.gamebotdev.com/
Sponsored content




PostSubject: Re: Multiple Monitors - Bot works, but no overlay. (solved by mazeez)   

Back to top Go down
 
Multiple Monitors - Bot works, but no overlay. (solved by mazeez)
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
The Game Bot Developers Community :: Members :: Sc2MapPro :: Users Guides-
Jump to: